Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TV bildet i Mediaportal hakker ca hvert 10 sekund
14-11-2009, 22:26
Post: #11
TV bildet i Mediaportal hakker ca hvert 10 sekund
For å klargjøre littBig Grinu trenger en kort-server. Dette er i ditt tilfelle NewCS. Kortserveren kommuniserer med abb.kortet og deler ut kort-info. Dette kan den gjøre med forskjellige protokoller, newcamdserver er vel vanligst, radegast er et annet greit alternativ. NewCS kan settes til å sende ut kortdata på begge disse protokollene samtidig (men til forskjellige porter).SoftCAM er den greia som dekoder videostrømmen. Den kommuniserer med kortserveren for å få de riktige nøklene (ECM) til å gjøre dette. Flere versjoner av MDAPIFilter har en enkel SoftCAM innebygget som man kan benytte.Man trenger en greie som binder sammen SoftCAM'en og videostrømmen. For MediaPortal gjør MDAPIFilter denne jobben. For f.eks. DVBViewer gjør SoftCAS (tror jeg navnet var) den jobben. EMM er en greie kabelselskapet sender ut en gang i blant. Denne forteller abb.kortet hvilket abonnement du har og hvilke kanaler du skal ha tilgang til. Dette er en ting som utløper, og om den ikke oppdateres vil kortet stoppe å fungere etter en stund. Kortet må da settes tilbake i dekoderen og oppdateres. For GET så kan man sende en tekstmelding for å få de til å sende en ny EMM. Radegast-protokollen støtter ikke sending av EMMs.Hvilken versjon man benytter av de forskjellige komponentene spiller en vesentlig rolle. Det slippes nye versjoner, og om du ikke får til en greie med en eldre versjon, så prøv med en nyere. Og omvendt.Så da er spørsmålet hvilken versjon du benytter av de forskjellige tingene.Selv benytter jeg NewCS 1.65. Dette er den siste versjonen av programmet som også finnes til Windows. Skal man kjøre en nyere NewCS må man gjøre dette på en linux-boks.Jeg benytter Acamd 6.1.1 (som jeg tror er nyeste). Jeg tror MDAPIfall2009 er siste versjon av MDAPI-filteret.Hvilke versjoner bruker du?
Find all posts by this user
Quote this message in a reply
14-11-2009, 22:46
Post: #12
TV bildet i Mediaportal hakker ca hvert 10 sekund
Hva mener du forresten med at radegast ikke fungerte?satte du i "cardclient.conf"-fila en # forran "necamd..." linja? og tok bort # forran en "radegast..." linje?radegast-linja skal i ditt tilfelle se slik ut:
Find all posts by this user
Quote this message in a reply
15-11-2009, 13:54
Post: #13
TV bildet i Mediaportal hakker ca hvert 10 sekund
HeiVed å enable radegast så ble det mer ustabilt enn med newcamd enabled. Jeg har brukt kun den innebygde klienten i MDAPIFilter og bør kanskje prøve med ACamd. Prøver med ACamd klient og ikke den innebygde.MDAPIFilter fra 1.5.2009 har nå satt actAsCardClient=falseNewCS versjon 1.65 startet med både radegast og newcamd.ACamd versjon 0.6.11 lagt acamd.dll og cardclient.conf under det enkelte kort.Grunnen til at jeg prøvde med en Linux burk er at det ser ut til å hakke hver gang den kaller kortserveren. Det er selvsagt på et lokalt trådløst nett.Prøver og ser om det blir mer stabilt med ACamd som klient.
Find all posts by this user
Quote this message in a reply
15-11-2009, 14:00
Post: #14
TV bildet i Mediaportal hakker ca hvert 10 sekund
:-\ Har nå testet med ACamd som klient og det hakker fortsatt hvert 10 sekund. Da var det ihertfall ikke klienten som gjorde det....Står litt fast nå...
Find all posts by this user
Quote this message in a reply
15-11-2009, 18:23 (This post was last modified: 15-11-2009 21:43 by jormikal.)
Post: #15
TV bildet i Mediaportal hakker ca hvert 10 sekund
Har nå også testet med siste MDAPIFilter, bildet ble bedre (skarpere) men hakkingen forsvant ikke. Men... denne virker veldig ustabil. TVServer krasjer hver gang man bytter kanal. Har derfor gått tilbake til forrige MDAPIFilter.Kan problemet være at kortserveren og kortklienten kjører på samme pc eller kan det være et codecs problem? Det hakker ikke på rene FTA kanaler.
Find all posts by this user
Quote this message in a reply
16-11-2009, 02:33
Post: #16
TV bildet i Mediaportal hakker ca hvert 10 sekund
[quote author=jormikal link=topic=539.msg3878#msg3878 date=1258302233]Har nå også testet med siste MDAPIFilter, bildet ble bedre (skarpere) men hakkingen forsvant ikke. Men... denne virker veldig ustabil. TVServer krasjer hver gang man bytter kanal. Har derfor gått tilbake til forrige MDAPIFilter.Kan problemet være at kortserveren og kortklienten kjører på samme pc eller kan det være et codecs problem? Det hakker ikke på rene FTA kanaler.[/quote]Får du til å skru på mer logging ?
Find all posts by this user
Quote this message in a reply
17-11-2009, 18:08 (This post was last modified: 17-11-2009 19:32 by jormikal.)
Post: #17
TV bildet i Mediaportal hakker ca hvert 10 sekund
Klarer nå å dekode og se de fleste kanaler (HD og digitale), men det hakker fortsatt hvert 10 sekund. Har prøvd flere codecs. Ser ut til at dekoding går bra. Men at det hakker hver gang det kaller kortet.Har testet med den interne MDAPIFilter klienten og med ACamd klient både mot kortserver på samme pc og på en annen server.[quote author=t1ger link=topic=539.msg3881#msg3881 date=1258331596]Får du til å skru på mer logging ?[/quote]t1ger hvilke loggfiler tenkte du på?Hvilken EPG bør jeg bruke på Mediaportal? Hvordan event koble til http://epg.mspc.no/xmltv/ ?
Find all posts by this user
Quote this message in a reply
17-11-2009, 21:06
Post: #18
TV bildet i Mediaportal hakker ca hvert 10 sekund
Merkelig den hakkingen. Har du prøvd å aktivere EMM (med newcamdprotokoll og acamd)? Blir hakkingen verre da? Har du aktivert NewCS-server, logget inn og sett om den får noen bad ecm's? Du kan jo laste ned MyTheatre, kjøre det med den samme softcammen/cardserver og se om bildet fortsatt hakker. Om det ikke gjør det så vet du at det mest trolig er MDAPIen som er problemet. MyTheatre trial lar deg kjøre programmet som betal-versjonen med det unntak at programmet automatisk avslutter så snart det har gått en time. Så er det bare å starte programmet igjen, og du har en ny time.Tenkte jeg skulle lage en kjapp manual til MyTheatre og DVBViewer og hvordan få satt disse opp mot GET i wikkien, men har ikke rettigheter til å skrive der enda, må ha minst 25 innlegg. Kommer stadig nærmere Wink
Find all posts by this user
Quote this message in a reply
18-11-2009, 00:39
Post: #19
TV bildet i Mediaportal hakker ca hvert 10 sekund
[quote author=jormikal link=topic=539.msg3913#msg3913 date=1258474124]t1ger hvilke loggfiler tenkte du på?[/quote]Det enkleste er kansje å logge på newcs på port 1001 og sette på verbose og se hva som skjer hvert 10 sek ?
Find all posts by this user
Quote this message in a reply
25-11-2009, 21:32 (This post was last modified: 26-11-2009 23:20 by jormikal.)
Post: #20
TV bildet i Mediaportal hakker ca hvert 10 sekund
Hei igjenBeklager sen tilbakemelding...Ser ut til at hakkingen er hver gang
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)