Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HD problem dvb-c
03-04-2010, 19:32
Post: #1
HD problem dvb-c
Jeg har dvb-c fra canaldigital og trøbler med å få noen av HD kanalene til å virke.Problemet er at hvert 1-2 sek pauser avspillingen 1/10 eller 2. Samtidig logger mythfrontend"prebuffering pause" (mer log nedenfor). LiveTV og opptak oppfører seg identisk.Hardwaredetaljer
Code:
Backend Core2 Duo 2.66Ghz, 2Gb memUbuntu 9.10mythtv 0.22-fixesTerratec Cinergy-CFrontendCore2 Quad 2.33Ghz, 4Gb memFreeBSD 8-stablemythtv 0.22-fixesNvidia 9500GT, native nvidia driver 195.22
Jeg utelukker ressursmangel på maskinene som årsak til problemet: - lesing fra disk på backend gir over 90Mb/sek ("cp kjempefil /dev/null") - iperf mellom BE-FE viser over 90Mb/sek - top rapporterer 65% CPU idle under avspilling - stabil høy signalstyrke og S/N, ingen forskjell på kanaler som virker/ikke virkerJeg har prøvd å variere det meste av settinger (forskjellig renderer, forskjelligedeinterlacere, etc) uten noen synlig effekt. Eneste endring jeg har sett er hvis jeg slårav "extra audio buffering".
Find all posts by this user
Quote this message in a reply
04-04-2010, 01:50
Post: #2
HD problem dvb-c
Opengl vsynch på ? Slå det av.Prøv å drepe pulse audio.Vilken out device har du ?Prøv å slett/rename .asoundrc
Find all posts by this user
Quote this message in a reply
04-04-2010, 19:36
Post: #3
HD problem dvb-c
Saken tok en interresant vending idag når jeg rekompilerte og installerte siste versjon av 0.22-fixes.Jeg fikk da vdpau til virke, noe jeg ikke har fått til før. Med det på plass spiller nå alle hdkanalene perfekt.Idle CPU under avspilling ligger nå på ~95% totalt, og med vdpau og advanced(2x) deinterlacing brukermythfrontend ~3% av en core (!)Konge ;D
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)