Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Oscam og tvheadend
06-02-2016, 21:37
Post: #11
RE: Oscam og tvheadend
(06-02-2016 19:37)tingo Wrote:  Hvilken versjon av tvheadend bruker dere?
En 4.1 utgave jeg kompilerte opp i januar: 4.1-1386~gb261275
Find all posts by this user
Quote this message in a reply
07-02-2016, 20:17
Post: #12
RE: Oscam og tvheadend
(06-02-2016 19:37)tingo Wrote:  Hvilken versjon av tvheadend bruker dere?

Jeg installerer siste daily build med jevne mellomrom. Hadde 4.1-1449~gdd2995e installert da jeg fikk til EMM.
Find all posts by this user
Quote this message in a reply
18-02-2016, 23:11
Post: #13
RE: Oscam og tvheadend
Jeg sliter veldig med å få oppdatert EMM med min installasjon av Tvheadend og OSCam. Begge kjører på Synology NAS.
Dette fungerte fint før, men da jeg byttet til ny NAS og installerte alt på nytt sluttet det å virke.

For meg kan det se ut som Tvheadend ikke sender EMM i det hele tatt. Det finnes i alle fall ingen spor i Tvheadend sin logg på noe EMM. Burde det ikke være der?
Kjører newcamd i Tvh mot Oscam på samme maskin, og EMM er krysset av. Dekoding og alt annet fungerer som det skal, men entitlements går ut på dato hver måned. Ganske irriterende.

Versjon av Tvh er 4.1.1207

Takker for innspill!
Find all posts by this user
Quote this message in a reply
19-02-2016, 09:56
Post: #14
RE: Oscam og tvheadend
(18-02-2016 23:11)Geeky Wrote:  Jeg sliter veldig med å få oppdatert EMM med min installasjon av Tvheadend og OSCam. Begge kjører på Synology NAS.
Foreslår at du dropper å kjøre newcs-protokoll og går over til dvbapi ("OSCam net protocol (rev >= 10389)" i TVheadend). Sjekk trondmm sin post for konfigfiler og oscam-versjon.

De eneste endringene jeg har gjort fra disse filene er å legge inn en:
Quote:blockemm-g = 1
i oscam.server. Dette fordi det plutselig strømmet inn med globale EMM som jeg neppe har noe bruk for.

Jeg ser i hvert fall at kortet mitt får nye koder når jeg sender SMS til GET og ber om oppdatering.
Find all posts by this user
Quote this message in a reply
25-02-2016, 23:17
Post: #15
RE: Oscam og tvheadend
(19-02-2016 09:56)urk Wrote:  Foreslår at du dropper å kjøre newcs-protokoll og går over til dvbapi ("OSCam net protocol (rev >= 10389)" i TVheadend). Sjekk trondmm sin post for konfigfiler og oscam-versjon.

Takk for svar!
Har forsøkt å bruke dvbapi, men får det rett og slett ikke til å fungere. Får ingen ECM. Brukeren som er definert med dvbapi i Tvheadend står som "offline" i OSCam uansett hva jeg gjør. De snakker tydeligvis ikke sammen over den protokollen. Konfigfiler skal være i henhold til oppskriften, så det er rart. OSCam er versjon r11211, nyere får jeg ikke tak i til min Synology med Annapurna Labs Alpine platform. Men problemet er uansett at Tvh aldri sender EMM til OSCam. Om Tvh får EMM fra tuner vet jeg ikke, finnes det en måte å sjekke det på?
Tuner er DigitalDevices Octopus.net.

Hvorfor mener du forresten at dette vil fungere bedre med dvbapi enn med newcs?

(19-02-2016 09:56)urk Wrote:  Jeg ser i hvert fall at kortet mitt får nye koder når jeg sender SMS til GET og ber om oppdatering.

Ok, kommer de ikke automatisk? Jeg har CD, de skal da komme av seg selv. Om jeg setter kortet i en Dreambox med cccam blir det oppdatert på no time, helt av seg selv. Slik fungerte det også tidligere med Tvheadend/OSCam.

Nå har jeg oppgradert Tvh til versjon 4.1.1556, ingen endring. Skal forsøke dvbapi på denne også. Naste skritt blir vel å sette opp Dreamboxen som kortserver/proxy for OSCam, så er problemet løst. Men det er jo litt nederlag....
Find all posts by this user
Quote this message in a reply
26-02-2016, 00:24 (This post was last modified: 26-02-2016 01:05 by Geeky.)
Post: #16
RE: Oscam og tvheadend
(25-02-2016 23:17)Geeky Wrote:  Nå har jeg oppgradert Tvh til versjon 4.1.1556, ingen endring. Skal forsøke dvbapi på denne også. Naste skritt blir vel å sette opp Dreamboxen som kortserver/proxy for OSCam, så er problemet løst. Men det er jo litt nederlag....

Da fikk jeg dvbapi til å funke! Aner ikke hvorfor, antar nyere versjon av Tvh gjorde susen. For godt mål slettet jeg alt av newcam-spor i configgen også.

Blir spennende å se om det dukker opp EMMs nå!

Ser ut som det funker! Big Grin

Dukker opp masse EMM-ting i OSCam-loggen nå:
2016/02/25 23:59:02 2445F861 c (reader) Smargo [conax] EMM: emm count 2 rewrite 3
2016/02/25 23:59:02 2445F861 c (reader) Smargo [conax] EMM: emm is being sent to reader

Og under Readers og EMM Written står det 0/0/38/0

Så da bør det være i orden.

Tusen takk for hjelpen, ser ut som oppgradering av Tvh i kombinasjon med dvbapi var det som gjorde susen!
Find all posts by this user
Quote this message in a reply
29-10-2016, 16:30
Post: #17
RE: Oscam og tvheadend
(26-02-2016 00:24)Geeky Wrote:  
(25-02-2016 23:17)Geeky Wrote:  Nå har jeg oppgradert Tvh til versjon 4.1.1556, ingen endring. Skal forsøke dvbapi på denne også. Naste skritt blir vel å sette opp Dreamboxen som kortserver/proxy for OSCam, så er problemet løst. Men det er jo litt nederlag....

Da fikk jeg dvbapi til å funke! Aner ikke hvorfor, antar nyere versjon av Tvh gjorde susen. For godt mål slettet jeg alt av newcam-spor i configgen også.

Blir spennende å se om det dukker opp EMMs nå!

Ser ut som det funker! Big Grin

Dukker opp masse EMM-ting i OSCam-loggen nå:
2016/02/25 23:59:02 2445F861 c (reader) Smargo [conax] EMM: emm count 2 rewrite 3
2016/02/25 23:59:02 2445F861 c (reader) Smargo [conax] EMM: emm is being sent to reader

Og under Readers og EMM Written står det 0/0/38/0

Så da bør det være i orden.

Tusen takk for hjelpen, ser ut som oppgradering av Tvh i kombinasjon med dvbapi var det som gjorde susen!

Kunne du ha postet ditt oppsett her? (for OSCAM og Tvheadend)?

Hvilken versjon av Tvheadend og Oscam kjører du?

IPTV?
Find all posts by this user
Quote this message in a reply
29-10-2016, 20:51
Post: #18
RE: Oscam og tvheadend
(29-10-2016 16:30)jkaberg Wrote:  Kunne du ha postet ditt oppsett her? (for OSCAM og Tvheadend)?

Hvilken versjon av Tvheadend og Oscam kjører du?

IPTV?

Jeg har for øyeblikket følgende versjoner (På Synology DS2015xs NAS)
TVHeadend 4.0.8-1
Oscam 11279-1

Det blir vanskelig å poste hele oppsettet her, det er for mye. Si fra om det er noe spesielt du lurer på eller ikke får til.

Jeg kjører ikke IPTV som sådan. Jeg har Canal Digital kabel inn, fanger dette med en Digital Devices Octopus net nettverkstuner. Denne dukker opp som en TV adapter med 8 tunere i TVH helt av seg selv, men om den da er SAT>IP eller hva er jeg usikker på. Jeg tror den er det, men det spiller egentlig ingen rolle. Jeg må da sette opp alle de 8 tunerene (4 fysiske) for seg, det er enkelt.
Kortleseren er en Smargo USB SmartReader Plus som sitter i NAS boksen.

For å få det til å spille sammen må følgende gjøres:
TVH: Følgende oppsett under CAs:

Mode: OSCam net protocol (rev >= 10389)
Camd.socket Filename / IP Address (TCP mode): localhost
(siden jeg kjører TVH og OSCam på samme maskin, ellers må du ha IP-adressen til OScam serveren)
Listen/Connect Port: 9001

OSCAM KONFIG FILER:
Oscam.conf: # oscam.conf generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r11272
# Read more: http://www.streamboard.tv/svn/oscam/trun...m.conf.txt

[global]
logfile = /var/packages/oscam/target/var/log/oscam.log
logduplicatelines = 1
clientmaxidle = 0
nice = -10
maxlogsize = 10240
waitforcards = 0
lb_save = 300
lb_retrylimit = 900
lb_stat_cleanup = 48
lb_savepath = /var/packages/oscam/target/var/log/stat
ecmfmt = [CAID:c] [PID:p] [SID:s] [L:l]
failbantime = 120
failbancount = 5

[cache]

[dvbapi]
enabled = 1
au = 1
pmt_mode = 4
request_mode = 1
listen_port = 9001
user = dvbapi
boxtype = pc

[webif]
httpport = 9000
httprefresh = 5
httpshowmeminfo = 1
httpshowloadinfo = 1
httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255,10.0.0.0-10.255.255.255,172.16.0.0-172.31.255.255
aulow = 120
hideclient_to = 120

# oscam.user generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r11272
# Read more: http://www.streamboard.tv/svn/oscam/trun...m.user.txt

[account]
user = dvbapi
pwd = dvbapi
description = DVBapi user
caid = 0B00
monlevel = 4
keepalive = 1
au = Smargo
group = 1
ident = 0B00:000000
max_connections = 99

# oscam.server generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r11222
# Read more: http://www.streamboard.tv/svn/oscam/trun...server.txt

[reader]
label = Smargo
description = Smargo
protocol = smargo
device = /dev/ttyUSB0
caid = 0B00
detect = cd
mhz = 534
cardmhz = 369
group = 1
saveemm-unknown = 1
saveemm-u = 1
saveemm-s = 1
saveemm-g = 1

Mer er det egentlig ikke. Masse oppsett i TVH, men egentlig vedig enkelt. Følg denne rekkefølgen:
- Sett opp tuneren(e) under TV Adapters
- Definer et nettverk under Networks, kall det hva du vil, det er kun logisk
- Sett opp Muxene. Om du har Canal Digital finner du informasjon om detaljene på deres websider, det avhenger av hvor du bor. Det du må vite er frekvens, symbolrate og Constellation. Det holder som regel at du vet om dette for noen få kanaler, med Network Discovery vil TVH finne resten selv.
I stedet for å sete opp muxer manuelt kan du velge "Pre defined muxes" under Networks. Om du finner din leverandør der bør det fungere.

TVH vil scanne selv, og det vil dukke opp "Services", altså de kanaler TVH finner. Men for å få disse over til TV-kanaler må de "Mappes". Det holder å gjøre dette en gang, så lenge kanalen ikke bytter plass fra leverandøren.

Spør om det er noe annet du lurer på!
Find all posts by this user
Quote this message in a reply
29-10-2016, 22:01
Post: #19
RE: Oscam og tvheadend
(29-10-2016 20:51)Geeky Wrote:  
(29-10-2016 16:30)jkaberg Wrote:  Kunne du ha postet ditt oppsett her? (for OSCAM og Tvheadend)?

Hvilken versjon av Tvheadend og Oscam kjører du?

IPTV?

Jeg har for øyeblikket følgende versjoner (På Synology DS2015xs NAS)
TVHeadend 4.0.8-1
Oscam 11279-1

...

Spør om det er noe annet du lurer på!

Takk for svar :-)

Jeg har allerede satt opp oscam og Tvheadend med GET IPTV, men får ikke EMM oppdateringen. Ser ikke noe spor i hverken tvheadend eller oscam sin logg.

Har satt opp tvh til og skanne en mux hver uke for EMM oppdateringer uten hell, hjelper ikke og skanne denne manuelt heller :-(
Find all posts by this user
Quote this message in a reply
30-10-2016, 12:24 (This post was last modified: 30-10-2016 12:26 by Geeky.)
Post: #20
RE: Oscam og tvheadend
(29-10-2016 22:01)jkaberg Wrote:  Takk for svar :-)

Jeg har allerede satt opp oscam og Tvheadend med GET IPTV, men får ikke EMM oppdateringen. Ser ikke noe spor i hverken tvheadend eller oscam sin logg.

Har satt opp tvh til og skanne en mux hver uke for EMM oppdateringer uten hell, hjelper ikke og skanne denne manuelt heller :-(

Jeg hadde samme problem da jeg brukte en eldre versjon av TVH, samt Newcamd i stedet for dvbapi. Er ditt oppsett med tanke på versjoner og dvbapi det samme som mitt? Ikke noe Newcamd eller sånt?
Har du disse under Reader i Oscam?

saveemm-unknown = 1
saveemm-u = 1
saveemm-s = 1
saveemm-g = 1
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)